Caribbean Examinations Council
Start a new topic

Help!!! I can't login to RM Assessor


I am having a problem login into the RM Assessor's page. I downloaded silverlight and the RM page came up, but when I try to put in my user name and password it kept saying, 'Login unsuccessful and I should try again.

Could you please advice me as to what I should do? Is anyone else having this problem

15 people have this question
@ Bibi the chief will swns you an email when marking starts. I have heard from mine but I still do not have my log in user name or password. I just don't know what's going on here! Dis you guys get tour username Ana password through email on did you see it on your status?

Received the credentials, downloaded Silverlight but can't log in.

@ Kimberlee thanks for the info. I saw my emarking credentials on my status. Log in through the examiners portal and see if it is there


I did not send in a letter from my school so do you think that's why I haven't gotten my username and password?
I don't think that is the problem because I didn't send in any letter from my school as well
I just tried to send stuff in via email to CXC... because I don't know why I haven't received anything concerning my user name and password. I have everything else. I have all the details about marking and all that...
I just checked my status and still no credentials.
I'm yet to receive my login to rm. Don't understand what is going on.
I have emailed cxc repeatedly for the last month asking for the login credentials. However, all I have received is so couple open tickets awaiting resolution. No username or password.
I got mine. I think you will get it according to when your marking committee is organized and close to when marking starts. Don't worry.
I think Mathematics marking already started. Yet I haven't received my credentials. Maybe I'm not needed.
Did you hear from your supervisor? If you didn't most likely marking has not started. I did not receive my user name nor password but I did hear from my supervisor, and which I informed about the problem. So hopefully the latter will be resolved soon

I'm having the same problem, no info on logging in to the rm assessor. I am to mark Agricultural Science. I've emailed repeatedly but from a month ago but no response. It says still processing, I'm confused.

I'm right there with you. Still no credentials and I have been emailing and all I get in a being process ticket

Login or Signup to post a comment